Minecraft 1.17 Supported


Minecraft 1.17 Supported

No need to switch from your favorite version! Play together with friends on Hypixel using Minecraft version 1.8 and above.

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Yesterday at 5:50 AM Arcade Games / Wool Wars support, new features and fixes – Replay System Update

We are happy to announce that you will have access to replays of five newly supported games! They can viewed by clicking the message at the end of a game or by doing /games in a lobby. We also worked on a lot of improvements and bug fixes that all the other supported games are also benefitting from

Read on to find out more!

Oct 5, 2022 Spooktacular Halloween 2022

  • Halloween Sale – up to 25% off on the in-game store and 20% off the web store!
  • The Great Spook returns in SkyBlock!
    • Speak to the Tyashoi Alchemist in the Hub
    • New Lava Fishing
    • Candy Hunt Returns
    • New Turbo Bat Racers Courses
    • Bed Wars
    • SkyWars
    • Wool Wars
    • Housing
    • Prototype

    Sep 28, 2022 SkyBlock Patch 0.15 – Leveling, Balancing, and more!

    Today we are releasing the next major patch of SkyBlock which includes a new form of progression along with many balancing and QoL changes!

    Sep 21, 2022 10 Years of the Hypixel Forums

    I don’t know if anyone noticed, but today is a special day! In fact, today is the most special of days, in my opinion. That is right, today is the 10 year anniversary of the Hypixel Forums!

    Did you know, that before the Hypixel Minecraft network existed, there was the Hypixel Forums? If you want to look into a piece of Hypixel history, you can find the thread announcing the release of the forums here. So many great things have happened over the past 10 years that I couldn’t cover all of it even if I tried. However, I have found some very interesting statistics regarding this extensive history.


Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *